NOC:ctwug qos

From CTWUG Wiki
Jump to: navigation, search

Purpose

  • Remove simple quees where the comments starts with "AUTO"
  • Create Simple quees based on the comment on the interfaces where the interface comment starts with "client;256;". The "256" is the max kbps that the interface is allowed to upload.

Dependencies

Interface comments need to start with "client;max-kbps;some other comments". ie.

client;256;link to Aragon

Script

/queue simple
:local qos
:foreach qos in [find] do={
  :if ( [:pick [get $qos comment] 0 4] = "AUTO" ) do=[remove $qos]
}
/interface
:local qos
:foreach qos in [find] do={
  :local com [get $qos comment]
  :if ( [:pick $com 0 6] = "client" ) do={
    :local name [get $qos name]
    :local p1 ([:find $com ";"] + 1)
    :local p2 [:find $com ";" $p1]
    :local mb ([:pick $com $p1 $p2]*1000)
    :local com ("AUTO ".$name." BULK")
    /queue simple add interface=$name name=$com packet-marks=BULK comment=$com max-limit=("0/".$mb) direction=download disabled=yes
  }
}
/system script run ctwug_run